Turris

Error during agent addition process on downstream entity application
Resolved

The issue affecting our compliance platform has been fully resolved. All services are now operating normally.

Summary:

  • Issue duration: [TIME RANGE]

  • Root cause: [BRIEF EXPLANATION]

  • Resolution: [BRIEF DESCRIPTION OF FIX]

We have implemented additional monitoring to prevent similar issues in the future. We sincerely apologize for any disruption to your compliance workflows.

If you experience any ongoing issues, please don't hesitate to contact our support team at support@turrisfi.com.

Wed, Oct 29, 2025, 09:44 PM
(1 month ago)
·
Affected components

No components marked as affected

Updates

Resolved

The issue affecting our compliance platform has been fully resolved. All services are now operating normally.

Summary:

  • Issue duration: [TIME RANGE]

  • Root cause: [BRIEF EXPLANATION]

  • Resolution: [BRIEF DESCRIPTION OF FIX]

We have implemented additional monitoring to prevent similar issues in the future. We sincerely apologize for any disruption to your compliance workflows.

If you experience any ongoing issues, please don't hesitate to contact our support team at support@turrisfi.com.

Wed, Oct 29, 2025, 09:44 PM

Investigating

We are currently investigating reports of issues with our compliance platform. Our engineering team has been notified and is actively working to identify the root cause.

We will provide updates as more information becomes available. For urgent compliance matters, please contact our support team directly at support@turrisfi.com.

We apologize for any inconvenience this may cause.

Wed, Oct 29, 2025, 08:10 PM(1 hour earlier)